DockPanels can not be docked

StatusIDPriorityType
Closed24864MajorQuestion
ProfileReply
hoevermaClient

Hello support,

I tried to create a test project for ASP.NET DockPanels. My problem is that I can create "floating" dockpanels, but I can not dock them anywhere. If I drag a panel around, nothing happens. I think that there should appear a small control indicating the locations where docking is possible (center, borders and so on). But this does not happen. I created my test project according to the help article "getting started" of the dockpanels theme.
I wanted to attach my test project here, but when uploading, I always get an XHR error 413. I would appreciate very much if you could tell me what I am doing wrong.

Thank you, kind regards,
Markus

Attached files:

Replies

UserDescriptionPosted On
Vitali YazvinskiAgent

Hello Markus,
To make panel is able to be docked you should implement IDockManagerHolder.
Our documentation describes how to do this. Please, check this page in our documentation General Components - Dock Panels - Getting Started - Web. Also you can use sample described in documentation that supplied with Xafari Dockpanels product.
As concerns how to distinguish place where panel can be docked to or not you can see it on the last picture of documentation page described above, also you can try it in Xafari DockPanels demo center.
I hope the above is useful to you.

Best regards,
Vitali.

hoeverma

Hello Vitali,

thank you for your reply. I followed the instructions you pointed me to. In which class do you think I did not implement IDockManagerHolder? I implemented it in Default and in DefaultVerticalTemplateContent. Where else do I have to implement it?

Kind regards,
Markus

hoeverma

Hello Vitali,

please excuse my mistake. I just realized I have sent the wrong project. I apologize for that. Can I send you the correct project in any other way than uploading it here? Because uploading always produces this XHR error 413.
One more time, please excuse my mistake!

Kind reagrds,
Markus

Attached files:
Vitali YazvinskiAgent

Hello Markus,

We have gotten your sample. There is a problem in markup DefaultVerticalTemplateContent.ascx.
You should put the following

 <cc3:XafUpdatePanel ID="UPDockZone1" UpdatePanelForASPxGridListCallback="False" runat="server" 

                                                   width="100%" Height="100%" ScrollBars="Auto">

 <dx:ASPxDockZone ID="ASPxDockZone1" runat="server" Orientation="Horizontal" width="100%" Height="100%"/

 </cc3:XafUpdatePanel>

to some another place.
Look in attached file please.

Best regards,
Vitali

hoeverma

Hi Yury,

thank you for your help so far! But I can not see a difference between the file you attached and my version of this file. You say I should move the UPDockZone1 panel to another place. Where should I move it?

Kind regards,
Markus

Vitali YazvinskiAgent

Hello Markus,

Sorry I have sent you original file.
I can't say in which place exactly you should put it in. It depends on what you want to get as a result.
Please check these pages if you want to get aditional information How to: Customize an ASP.NET Template and Template Customization
I have uploaded file with example how it can be.

Thanks,
Vitali

hoeverma

Hello Vitali,

thank you again. I tried with the file you attached. The result in my project is still the same. I can open a dockpanel via the Panels menu. But the created DockPanel is floating and can not be docked anywhere. I sent you my project again in an email. Could you please check again?

Thank you,
Markus

Vitali YazvinskiAgent

Hello Markus,

I have uploaded your full yesterday's sample with changes, try it please. Also in attachment there is video how it looks.

Could you tell which browser do you use, please?

Best regards,
Vitali

This reply has been deleted 2 years ago.
hoeverma

Hello Vitali,

please excuse, I have to ask again: On my site, it does not work. In the avi file you attached, I see the dark rectangle appearing when you move around the docking panel. This rectangle does not appear in my application. I use internet explorer 9 and firefox 43.0.1. In both browsers, I get the same result.
Can you tell me how I could go on?

Kind regards,
Markus

Vitali YazvinskiAgent

Hello Markus,

Of course there are differences between browsers and how it handles the markup. You should keep it in mind.
My previous example works in modern IE and Chrome.
Look in attached file please. I have corrected it, so it works properly in Firefox 43.0.1.

Best regards,
Vitali

× This ticket is closed.

Write US