Exception Executing Aggregated Action

StatusIDPriorityType
Open34374CriticalBug
ProfileReply
Scott GrossClient

After updating to Xafari 17.2.7011.1444, our Aggregated Actions are now throwing the following exception:

System.NullReferenceException: Object reference not set to an instance of an object.
at DevExpress.XtraBars.ViewInfo.BarSelectionInfo.ClearHighlightTimer(Boolean always)
at DevExpress.XtraBars.ViewInfo.BarSelectionInfo.Clear()
at DevExpress.ExpressApp.Win.Templates.ActionContainers.Items.BarChoiceActionItem.control_ItemClick(Object sender, ItemClickEventArgs e)
at DevExpress.XtraBars.BarItem.OnClick(BarItemLink link)
at DevExpress.XtraBars.BarButtonItem.OnClick(BarItemLink link)
at DevExpress.XtraBars.BarItemLink.OnLinkClick()
at DevExpress.XtraBars.BarButtonItemLink.OnLinkAction(BarLinkAction action, Object actionArgs)
at DevExpress.XtraBars.ViewInfo.BarSelectionInfo.ClickLink(BarItemLink link)
at DevExpress.XtraBars.ViewInfo.BarSelectionInfo.UnPressLink(BarItemLink link)
at DevExpress.XtraBars.Controls.CustomLinksControl.OnMouseUp(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at DevExpress.XtraBars.Controls.CustomControl.WndProc(Message& msg)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I can provide the code, but it is strictly following the example in the documentation... unless recently updated.

The actions seem to execute and then display the above exception.

This seems to be difficult for me to trace, so any help would be great.

Thank you.

Replies

UserDescriptionPosted On
Scott Gross

After some more testing, this occurs on Detail Views, not the List View.
Aside from the Upgrade, I also Implemented The Object Status Feature: https://documentation.galaktikasoft.com/xafari/doc_object_status
adding the Object Status and setting the WinApp to use the old templates might be causing it?
The bug was reported only a few days after adding the Object Status.

MariyaVoytovichAgent

Hello Scott Gross,
Thanks for reporting the issue.
In order to fix the issue, we must first reproduce the issue in our labs. We are unable to reproduce the issue using our Demo FeatureCenter. We do not have ideas why this error can occur on your machine either.
Could you please provide us with the following info?
1. A small demo project, reproducing the problem;
2. Detailed steps to reproduce the problem.
We want to help you and are looking forward to hearing from you.

Regards,
Mariya
On behalf of Xafari Client Services Team

Scott Gross

Disabling the Old Templates resolves the issue, when time I'll try to reproduce with sample project.

Write US