Unable to install Toolbox with latest version

StatusIDPriorityType
Closed24681CriticalBug
ProfileReply
rkpittClient

Hello,
I just attempted to install your latest version for assessment (v15.1.708.574). Upon opening Visual Studio, your components were not present in the Toolbox, so I ran your application 'Install VS Toolbox'. That resulted in an un-handled exception:
System.IO.FileNotFoundException was unhandled
Message: An unhandled exception of type 'System.IO.FileNotFoundException' occurred in mscorlib.dll
Additional information: Could not find file 'C:\Program Files (x86)\Galaktika\Xafari Framework v15.1.708\Framework\bin\xti_config.ini'.

I checked the install path and the file xti_config.ini was not installed.

Can you please advise a procedure or workaround or issue a fix so that your components are accessible in the Toolbox?

Replies

UserDescriptionPosted On
Sasha (Xafari Support)Agent

Hello,

Thank you for your question. We are working on your issue and will get back to you as soon as we can. Please bear with us.

Regards, Sasha.

Sasha (Xafari Support)Agent

Hi,
Thanks, it is a bug of Xafari v15.1.708.574 really and we are going to fix the bug in next build of Xafari.

You can solve the problem yourself:
- change installation of Xafari v15.1.708.574:
ChangeInstalXafari
- select point "VisualStudio 2013 extensions" -> Next:
CustomSetup

Please, inform us of your results.
Thanks, Sasha.

rkpitt

Hello Sasha,
I followed these instructions exactly. It didn't work. The file is still missing and the toolbox items are still missing. I revert to previous version for now (it works) and wait for your improvements.
Thank you,
Richard

Sasha (Xafari Support)Agent

Hi,
Please, inform us what version of Xafari and DevExpress are you using?

Notes:
- modules of Xafari are added to the Toolbox VS automatically, when you select the Complete installing;
- modules of Xafari are added to the Toolbox VS automatically, when you select the Custom installing with point "VisualStudio 2013 extensions".
In this instance you do not have to run Install VS Toolbox. If your Toolbox does not contain Xafari modules you can reset the Toolbox:
ResetToolbox

We hope you find this information helpful.
Regards, Sasha.

rkpitt

Hello Sasha,

DevExpress v15.1.7 / Xafari v15.1.708.574. I did the install properly as per the instructions and your advice (Reset Toolbox, etc) No luck.
With DevEx 15.1.7 / Xafari v15.1.708.509, it works just fine.

Thanks,
Richard

Sasha (Xafari Support)Agent

Hi Richard,

Thanks for your patience and additional informations about the issue.
Please, wait for a new Xafari build.

Regards, Sasha.

Sasha (Xafari Support)Agent

Hello,
Please inform us of your results with issue «Unable to install Toolbox ...».

Regards, Sasha.

× This ticket is closed.

Write US