Using the Wizard from a Nested View

StatusIDPriorityType
Closed34863MinorQuestion
ProfileReply
RousesClient

Hello I am just starting to experiment with Xafari, I have created a wizard that is invoked from a nested view, when I use the standard New button, I get the parent reference inserted, I set a flag somewhere for this. However this does not occur with the Wizard I may be missing something, almost certainly I am. Can you point me in the right direction please? Thankyou in advance.

Replies

UserDescriptionPosted On
MariyaVoytovichAgent

Hello Rouses!

Our apologies for the delay.
You can read about the Wizard in the documentation: Wizards
Also you can send us your demo project with steps to reproduce the problem.

Feel free to contact us if you need further assistance or have additional questions.

Regards,
Mariya
On behalf of Xafari Client Services Team

RousesClient

Hello I have read the documentation on Wizards. I will send you some screen shots of what I am experiencing, I will do this tomorrow.

Regards

Steve

RousesClient

Hello sorry for the delay, I have created the attached PDF to illustrate my issue.

Regards
Steve

Attached files:
MariyaVoytovichAgent

Hello Rouses!

Our apologies for the delay.

We have prepared an example demonstrating the work of a wizard.
If you use a wizard for a saved room object, then the asset object is perfectly added.

Feel free to contact us if you need further assistance or have additional questions.

Regards,
Mariya
On behalf of Xafari Client Services Team

Attached files:
RousesClient

Hi Mariya

Thankyou for getting back to me, I have added the lines to my code, but this did not solve the issue, I had tried something similar previously. What I cannot understand is that the watch output shows the required link, except this is not "committed". I'll continue investigating. . .

Regards
Steve

MariyaVoytovichAgent

Hi Rouses!

You can send your demo project and we will try to help you.
–°an you provide us with the following information?
1. A small demo project, reproducing the problem;
2. Detailed steps to reproduce the problem.
We want to help you and are looking forward to hearing from you.

Regards,
Mariya
On behalf of Xafari Client Services Team

RousesClient

Hello Mariya

I have now managed to solve my issue, I was already experimenting with a similar method to the one provided, thankyou for reaffirming the approach, all I have done is to get a reference to the "MasterObject" and then "link this to the created object, before committing the ObjectSpace changes.

Works for me, I'm happy

Thank You

× This ticket is closed.

Write US